Online Chat
 Call Us: 
1-877-744-1221
Browse Submit a Ticket
 
Advanced Search
Tools
Rss Categories

Web server requirements (software)

Author: Edward Hardin Reference Number: AA-00468 Views: 29712 Last Updated: 11/20/2017 04:14 PM 45 Rating/ 5 Voters

This article provides detailed list of KMP requirements to a web server. It is intended for use by server administrator.

Go back to the requirements short-list on the website.

See the KMP installation guide.

Operating System

Any Windows or Unix-like.

Although all configurations listed below are supported in full, we recommend to use web server with Unix-like system and Apache.  This makes installation and maintenance of KMP easier.

Requirements for Windows server

Web Server Software (any from the list):

  • Apache v1.3+
  • Apache v2.2+
  • IIS6 
  • IIS7
  • IIS8

Scripting Language:

  • PHP v5.3.*, v5.4.*, v5.5.*, v5.6.* (VC11 x86 Non Thread Safe is recommended for IIS). PHP 7.* is NOT supported.

PHP extensions and settings:

  • Session support
  • zlib
  • cURL 
  • Disabled safe_mode option
  • PCRE with Unicode and UTF support. Bundled with PHP package starting from v5.3 and supports UTF and Unicode by default.
  • GD Library is required for CAPTCHA support (optional component)
  • PHP’s LDAP library is required to use LDAP functionality (optional component)

Database (any from the list):

Scheduler (for recurring tasks):

  • Windows Scheduler (always available as standard Windows tool)

Modules for attachments indexation (optional):

  • AntiWord (free) is required to index and search Microsoft Word 2003/XP documents
  • PHP’s zip library (free) is required to index and search Microsoft Word/Excel/PowerPoint documents
  • pdftohtml/poppler (free) is required to index and search Adobe PDF documents
  • PHP’s EXIF library (free) is required to index and search images meta data

All modules are free (see the Installation of the attachment indexation modules guide for details).


Requirements for UNIX-like server

Web Server Software (any from the list):

  • Apache v1.3+
  • Apache v2.2+
  • LigHTTPD v1.4.12+
  • ngnix

Scripting Language:

  • PHP v5.2.12+, v5.3.*, v5.4.*, v5.5.*, v5.6.*

PHP extensions and settings:

  • Session support
  • zlib
  • cURL 
  • Disabled safe_mode option
  • PCRE with Unicode and UTF support. Bundled with PHP package starting from v5.3 and supports UTF and Unicode by default. If you're using external PCRE library, you need to compile it with parameters --enable-utf8 and --enable-unicode-properties that enable UTF and Unicode support.
  • GD Library is required for CAPTCHA support (optional component)
  • PHP’s LDAP library is required to use LDAP functionality (optional component)

Database: 

Scheduler (for recurring tasks):

  • Cron (commonly available)

Modules for attachments indexation (optional):

  • AntiWord (free) is required to index and search Microsoft Word 2003/XP documents
  • ppthtml (free) is required to index and search Microsoft PowerPoint 2003/XP documents
  • PHP’s zip library (free) is required to index and search Microsoft Word/Excel/PowerPoint documents
  • UnRTF (free) is required to index and search RTF Documents
  • pdftohtml/poppler (free) is required to index and search Adobe PDF documents
  • PHP’s EXIF library (free) is required to index and search images meta data

All modules are free. See the Installation of the attachment indexation modules guide for details on installation.